For the best experience, we recommend downloading and using Google Chrome or Firefox to access Storypark. You can download the latest version of Google Chrome for free, here.

If something doesn't look right while you are using Storypark it may be because you are using an old browser.
 
The browsers we support are:


  • Google Chrome (current version)
  • Firefox (Version 3 to current)
  • Internet Explorer 9
  • Internet Explorer 8, although some features may be limited
  • Safari (Current version)


Internet Explorer users
Storypark is built to make the most of modern browsers. Modern browsers offer a better experience and enhanced security. So if you are using Internet Explorer 6 or 7, Storypark will not work properly for you.
 
If you are not sure what version you are using, open Internet Explorer by clicking the 'Start' button, and then select 'Internet Explorer'. Press ALT+H, and then click 'About Internet Explorer'. If it says you are using version 6 or 7, please upgrade to the latest version.
 
To upgrade Internet Explorer:

  • Open Windows Update by clicking the 'Start' button.
  • Select 'All Programs', and then 'Windows Update'.
  • In the left pane, click 'Check for updates'.
  • If any updates are found, click 'View available updates'.
  • Make sure the Internet Explorer updates you require are selected, and then click 'Install'.
Did this answer your question?